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MS Excel  

About Excel  
  

Microsoft Excel is a powerful Worksheet computing tool from Microsoft Corporation. It 

makes it easy for you to create various kinds of spreadsheets, tables and statements along 

with the graphical representation of data using graphs. While working in Excel, you can 

make use of its most important feature of automatic recalculation to save time and effort.   



ADVANCE EXCEL | PROFF.GAYATRI SHETH 

 

P a g e  5 | 80 

 

  

In Excel, you work with worksheets, which consist of rows and columns that intersect to 

form cells. Cells contain various kinds of data that you can format, sort, and analyze. You 

can also create charts based on the data contained in cells. An Excel file is called a 

workbook, which by default contains three worksheets.  

  

The Excel 2010 Ribbon  
 First impression of the 2010 ribbon was that it was cleaner and maybe a little smaller than 

in 2007. It is clear that the new ribbon was no smaller than before, still a good row taller 

than an overloaded toolbar area in 2003. But the 2010 ribbon definitely is cleaner.  

The 2003 interface is pretty cluttered, efficient interface that displays all of my most-used 

commands at once, without hiding 90% of them. The 2007 ribbon looks nearly as cluttered 

as the classic toolbar interface, not because it has lots of controls, but because everything 

is in boxes, and there is no shortage of graded coloring.  

The 2010 ribbon has the same density of controls as in 2007, but it looks cleaner because 

of its lighter background and the elimination of much of the chart-junk-like features.  

Instead of boxes around all of the groups of controls, as in 2007, the groups are separated 

by a single light line, and the shadowing is much less pronounced.  
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A Designer Cleans up the 2007 Ribbon  

A year ago Andreas Lipphardt of XLCubed wrote Microsoft, Pimp Down My Ribbon, a 

request to clean up the 2007 ribbon. He even showed how. He started with the ribbon out 

of the box:  

  

Andreas cleaned up the ribbon by removing all the gradients and glows, and without all 

of the gratuitous effects, it certainly looked much cleaner.  

  

Microsoft stopped here with the 2010 ribbon, but Andreas took it one step further, 

removing the large office button and the oversized ribbon buttons (e.g., Paste), and closed 

up the excess space. This was becoming too much like the classic interface.  

  

Why Can’t Users Clean Up Their Own Ribbons?  

Now they can, to some extent. Microsoft has added the ability to make changes to the 

interface through the interface. Even though RibbonX, the ribbon-specific subset of XML, 

is relatively easy to use to customize the interface, RibbonX is still way beyond a typical 

user‘s capabilities. This ribbon customization capability gives back to the user some small 

measure of control, maybe 10% of what we once had.  
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Charting on the Ribbon  

I‘ll show a couple shots to further illustrate the cleaner ribbon appearance in 2010. Here 

are the Charts groups from the Insert tabs of Excel 2007 and 2010.  

  

  

Although the 2010 group looks much cleaner, the buttons are all the same as before, and in 

fact, all the options under the buttons are the same. The gallery of chart types in 2010 is 

just like that in 2007. The Chart Tools contextual tabs are also cleaner but with essentially 

no real changes. The one addition is a Draft Mode button on the Design tab. Its purpose is 

to allow charts to be drawn with only rudimentary formatting, to speed up screen refreshing 

in Excel 2007.  
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A Couple New Features – Look But Don’t Touch  

However, right next to the Charts group on the Excel 2010 Insert tab are two new groups: 

Sparklines and Filter, which houses the Slicer. These much heralded features are probably 

the most talked about new tricks in Excel 2010. The advance press for Sparklines on the 

MSDN Excel blog is very promising.  

  

At first I thought that neither feature is enabled for testing in this early preview version. I 

didn‘t notice that I was using Compatibility Mode, which disables advanced features 

introduced in 2007 and later..  

Chart Dialogs  

I made a few charts, just to see what if anything has improved in the awkward Excel 2007 

dialogs. One thing has changed: after being temporarily retired for one version, the ability 

has returned to double click on a chart element to open its format dialog! Unfortunately the 

dialogs that open up are unchanged from those of 2007. Too many tabs, too many options 

hidden in dropdowns when there is ample space to use list boxes or option buttons, too 

many clicks required to do otherwise quick tasks. And the F4 (Repeat Last Action) 

command is still AWOL. It remains to be seen whether any changes will be forthcoming 

in upcoming releases of the preview.  

I‘ve been working on a charting interface add-in for Excel 2007, and I suspect that it will 

be useful for users of Excel 2010 as well.  

Macro Recorder  

I recorded a few macros, nothing too complex, to see whether the huge gaps in Excel 2007′s 

macro recorder coverage have been addressed. In 2007 if you recorded a macro while doing 

anything with shapes, the macro came out blank. When working with charts, some actions 

were recorded, but many were missed, particularly those related to formatting of the shapes 

that make up the chart‘s elements. Because the recorder didn‘t record, we were without a 

tool that was so helpful to decode the intricacies of the object model.  

Without examining the details, I was able to see that all actions were represented by 

commands in the recorded macros. Shapes and chart element formatting were again 

represented in the code. This is a great (re)addition to a developer‘s toolbox.  
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Summary  
Excel 2010 looks a bit cleaner and seems to run a bit more smoothly than Excel 2007. In 

the small part of Excel that I have examined, very little has changed. I will be looking at 

Spark lines and other neat new stuff in the near future.  

  

Interacting with Excel 2010  
You interact with Excel by typing and by using the mouse to choose commands, make 

selections, and click buttons and options.  

  

Using the Ribbon  

  

The Ribbon is the main location for menus and tools. When you choose a Ribbon tab, the 

Ribbon displays Ribbon groups that contain tools such as buttons and lists. Some of these 

tools expand to display simple lists, and some display galleries, as shown in Error! 

Reference source not found.. A list is a collection of related commands or selections. A 

gallery is an interactive list.  

  

Using galleries  

  

Selections on a gallery display the result of the selections in Excel, rather than just a list 

of options. Some galleries use live preview. When you move the pointer over options on 

a gallery, each option is previewed on whatever is selected on the worksheet. For 

example, if you select text in the worksheet, and display the Font gallery, moving the 

pointer over each font in the gallery causes the selected text on the screen to display in 

that font.   

  

Using tools  

  

When you point to a tool, a description called a super tool tip appears. The super tool tip 

provides less description than Help, but more than an ordinary screen tip  

Changing default 

settings  

  

Excel allows you to change many 

aspects of its behavior and how you 

interact with it. You can change 

default settings such as number of 

iterations, font, file locations, and the 

file that opens on starting Excel. To 
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select the dialog box of Options you need to click on File Tab-> Option and select the 

required tabs from the dialog box.  

Personalize options  

  

You can change workbook settings by using the personalize options such as Type of Font, 

Size of the font, number of worksheet in workbook and can also activate the Developer 

tab , which is used for Macro.  

  

Save option  

   

Save option allows you to change the default file location, File Format, and Auto save the 

file.   

Understanding Cell Reference and Range Name  
  

Using relative references  

  

Relative references are the default cell reference in Excel, and they make it easy for you 

to create formulas once and then copy them. If you copy the formula the cell reference 

changes from A1 to B1 if you copy column wise and if you copy row wise it will change 

to A2. There are situations, however, in which you don't want Excel to adjust a reference 

relative to the location of a copied formula. For these situations, Excel provides for 

absolute references and mixed references.  

Limitations of relative references  

  

Usually, relative references work very well when you copy a formula. But if the formula 

refers to a specific cell that should not change, then you need to type or edit the formula 

again if you are not aware of freezing the cell. This can happen when you refer to 

commission or discount rates which are typed in one of the cell and need to create a 

formula and copy.  

Absolute references  

  

When you don‘t want a reference to change when you copy it, you can use an absolute 

reference. To make a reference absolute, you place a dollar sign in front of both the 
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column letter and the row number for the reference. For example, to create an absolute 

reference to cell A1, you would enter $A$1. When you copy an absolute reference to 

another location, Excel will not adjust the reference.  

  

  A  B  C  D  

  

1  100000  10%  11%  12%  

2    =$A$1*B1  =$A$1*C1  =$A$1*D1  

  

Mixed references  

  

You can also create mixed references by placing a dollar sign in front of only the column 

letter or the row number. When copied, the relative part of the reference will adjust 

relative to the new location, while the absolute part will not. You can cycle through the 

reference possibilities as soon as you enter a reference by pressing F4, e.g., $A1 or A$1, 

so if use $A1 means the Column is fixed and if your type A$1 then Row is fixed.  

Example   

  

  A  B  C  D  

  

1  100000  10%  11%  12%  

2    =$A1*B1  =$A1*C1  =$A1*D1  

  

Working with Range Name  

  

Generally when we create a formula or function we generally refers to the cell reference 

such as sum(A2:A200).If cells A2:a200 contains the Salary of East Region, wouldn‘t the 

spreadsheet easier to understand if the formula was sum(EastRegion)? Or if we create a 

formula from different sheet, generally get the formula with different sheet name and the 

range name instead of that we can create formula using range name. We will see how to 

name the individual cell, range of cells  

  

There is different way of creating Range Name  

• Entering a range in the Name box  

• Choosing the Name, from the Insert Menu  

• Choosing the Name, Define command from Insert Menu  

Using Name Box and Creating a Range Name  
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On a Formula bar on the left hand side there is name box, simply select the cell or ranges 

of the cells that you want to specify name, click on the Name box, type the name you 

want to use. Press Enter, and you‘ve 

created the range name.  Name Box  

Clicking on the Drop down arrow for the 

Name box displayed the range names in a 

workbook by pressing F3 button.  

  

  

  

To name a cell or range, follow these steps:  

1. Select the cell or cell range that you want to name.  

You also can select noncontiguous cells (press Ctrl as you select each cell or range).  

2. On the Formulas tab, click Define Name in the Defined Names group.  

The New Name dialog box appears.  

  
Use the New Name dialog box to assign a name to the selected range.  

3. In the Name text box, type up to a 255-character name for the range.  

Range names are not case-sensitive; however, range names must follow these conventions:  

• The first character must be a letter, an underscore, or a backslash.  

• No spaces are allowed in a range name.  

Formula Bar 
  

http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-tabs
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-tabs
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-dialog_box
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-dialog_box
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-dialog_box
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-dialog_box
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• The range name should not be the same as a cell address. For example, you can't name a range U2 

or UB40, but BLINK182 and ABBA are just fine.  

   Click OK.  

  

Creating Range Name by Using the Name 

Define Command.  

  

Suppose if you want to assign the name Prn to the 

cell range A1:K7, select the range, click on   

Formula Tab, in Named Cells Group click on Name 

Range command in the given dialog box type the 

name and click OK.  

  

If you click on Name Manager from Name cell group, it allows you to Add, Edit or 

Delete the Name from the Workbook.  

Working with Formulas and Function  
  

Using Formulas in a Worksheet  
  

Formulas are equations that perform calculations on values in your worksheet. A formula 

starts with an equal sign (=). For example, the following formulas multiply 2 by 3 and 

then add 5 to the result.  

=5+2*3  

  

A formula can also contain any or all of the following: functions, references, operators, 

and constants.  

Using array formulas  
  

An array formula enables you to perform many calculations by using a single formula. 

For example, consider a worksheet containing quantities in one-column and unit prices in 

another, as shown below.  

  

http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-cell_address
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-cell_address
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-cell_address
http://www.dummies.com/how-to/content/how-to-name-a-cell-or-range-in-excel-2010.html#glossary-cell_address
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In cell B8, you want to calculate the total sales of items without calculating the sales 

amount of individual items. You can do so by using the array formula shown below. This 

formula multiplies the quantity by the unit price for each item, and then adds all the 

results.  

  

In the formula, A2:A6 and B2:B6 are known as array arguments. Each array argument 

must have the same number of rows and columns. After entering array formula, press 

Ctrl+Shift+Enter, instead of simply presses the Enter key. When you enter a formula this 

way, it will appear on the Formula bar enclosed in brackets ({}), indicating that it is an 

array formula.   

  

Working with Functions  

 
Figuring out formulas for calculations you want to make in Excel can be tedious and 

complicated. Fortunately, Excel has an entire library of functions or predefined formulas 

that you can take advantage of. You may be familiar with common functions like sum, 

average, product or count, but there are hundreds of functions in Excel, even for things 

like formatting text, referencing cells, calculating financial rates, analyzing statistics, and 

more.   

In this lesson, you will learn the basics of inserting common functions into your 

worksheet by utilizing the AutoSum and Insert Functions commands. You will also 

become familiar with how to search and find various functions, including exploring 

Excel's Functions Library.  
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Performing calculations on each value in a range of cells can be complicated and timeconsuming. 

For example, if you have a range consisting of 20 cells, a formula that adds each of these values 

will be very long. Excel functions simplify complex tasks. A function is a predefined formula that 

performs a specific calculation or other action on a number or a text string. You specify the values 

on which the function performs calculations  
  

The syntax of a function begins with the function name, followed by an opening 

parenthesis, the arguments for the function separated by commas, and a closing 

parenthesis. If the function starts a formula, type an equal sign (=) before the function 

name .As you create a formula that contains a function, the Formula Palette will assist 

you.  

 =Function_name(argument1,argument2,….)  

  
=SUM (A10, B5: B10, 50,37)   

  

You don‘t need to memorize all the functions available and the arguments necessary for each 

function. Instead, you can use the Insert Function dialog box, which lists all the available 

functions. When you choose a function, Excel prompts you for required and optional arguments.   

IF function  
  

Suppose in salary worksheet if you want to calculate HRA according to condition wise,  

i.e. Manager 1000, Officer 750 and clerk 500, or if you want to calculate Income tax slab 

wise.  

  

In the above scenario you can use the IF function to evaluate a condition. The IF function 

returns different values depending on whether the condition is true or false. The syntax 

for the IF function is:  

  
If(Condition ,True, False)  

  

The first argument is the condition that you want the function to evaluate; the second 

argument is the value to be returned if the condition is true, and the third argument is the 

value to be returned if the condition is false.  

  

Example  

  

Suppose you want to calculate HRA based on designation of the employees, if 

Designation is Manager then HRA is1000 or else 500. Then the function code will be as 

follows:  
=if(D2="Manager",1000,500)   
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Nesting Function using IF  
  

In certain cases, you may need to use a function as one of the arguments of another 

function, for example if it is manager 1000, officer 750, and clerk 500.  

  

The syntax for the Nested IF function is:  
If(Condition ,True, if(Condition ,True,False))  

  

Example  

You can use nested IF functions to evaluate complex conditions. For example, if the 

Salary <5000 then tax is 5%, if salary between 5000 and 1000 then it is 10% else 15%.   

  
=if(salary<5000,salary*.05,if(salary<10000,salary*.10,salary*.15))  

  

Note: Replace Salary with Cell Reference.   

  

Suppose you want to assign letter grades to numbers referenced by the name Average 

Score. See the following table.  

  

  

  

If Average Score is  Then return  

Greater than 89  A  

From 80 to 89  B  

From 70 to 79  C  

From 60 to 69  D  

Less than 60  F  

  

  

You can use the following nested IF function:  

      
IF(AverageScore>89,"A",IF(AverageScore>79,"B",IF(AverageScore>69,"C",IF(Average 
Score>59,"D","F"))))  

  

Note: Average Score will be the cell address of the cell. Excel allows maximum seven IF 

functions in a formula.   

IF function [Using And/ Or/ Not]  
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AND  

  

Suppose if you want to calculate HRA based on condition, i.e. if the Employee is 

Manager and his Grade is A1 if both the condition are satisfied then HRA will be 50% of 

salary, in such scenario you can use AND function with if condition.  

  

AND is a logical function, which is used when there are multiple conditions in a formula. 

When all the conditions are satisfied then it will return True value else returns the false 

value.  

  

Syntax using And with If   

  
If(and(Condition1,condition2….),T,F)  

There can be maximum 30 conditions which can be passed to AND function.  

  

Example:  

If the Employee is Manager and his Grade is A1 then calculate HRA as 50% of salary or 

else 30% of salary.   
=if(and(d2="manager",e2="A1"),g2*.5,g2*.3)  

  

OR  

  

Suppose if you want to calculate HRA based on condition, i.e. if the employee is  

Manager or his Grade is A1 in such scenario you can use OR function with If condition.  

  

OR is a logical function, which is used when there are multiple conditions in a formula. 

When any one of   the condition is satisfied then it will return True value else returns the 

False value.  

Returns TRUE if any argument is TRUE; returns FALSE if all arguments are FALSE.  

  

Syntax  

OR(logical1,logical2,...)  

Logical1,logical2,...   are 1 to 30 conditions you want to test that can be either TRUE or 

FALSE.  

  

Syntax with If condition  

  

If(or(condition1, condition2,...)  

There can be maximum 30 conditions which can be passed to OR function.  

  

Example:  

If the employee is in Sales, Mktg or Hrd, then hra is 50% of salary or else 30% of salary  
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Eg.if(or(b2="Mktg",b2="Sales",b2="Hrd"),h2*.5,h2*.3)   

  

NOT  

  

Suppose if you want to calculate HRA   i.e. except Marketing Dept then you can use NOT 

Function using If.  

  

Not function can have only one condition.  

  

Example:  

If the employee does not work in mktg then hra is 50% of salary or else 30% of salary.  

  
Eg.if(not(b2="Mktg"),h2*.5,h2*.3)  

  

Note: From the XP version while writing the function syntax is displayed   

  

Working with VLOOKUP Function  
  

Given Employee Id, how can I look up the Incentive value from some other sheet or some 

other file?  

Vlookup- stands for Vertical Lookup. If we want to the get the value of one column from 

some other file or sheet based on common field then you can used function vlookup. It 

searches for a value in the leftmost column of a table, and then returns a value in the same 

row from a column you specify in the table.   

  

Syntax  
VLOOKUP(lookup_value,table_array,col_index_num,range_lookup  

  

You can use this function using in Built Function, Select Insert Menu- and Click on Insert 

Function or click on Fx from formula bar- Select Lookup & Reference category and 

select Vlookup, you will get a dialog box as shown below,   



ADVANCE EXCEL | PROFF.GAYATRI SHETH 

 

P a g e  19 | 80 

 

  
  

  

Lookup_value   is the value to be found in the first column of the table. Lookup_ value 

can be a value, a reference, or a text string.  

  

Table_array   is the table of information in which data is looked up. Use a reference to a 

range or a range name.   

  

Col_index_num   is the column number in table_array from which the matching value 

must be returned.   

  

Range_lookup   is a logical value that specifies whether you want VLOOKUP to find an 

exact match or an approximate match. If FALSE, VLOOKUP will find an exact match. If 

one is not found, the error value #N/A is returned. If it is true then it finds the, the next 

largest value that is less than lookup value is returned.  

  

Example of Vlookup with False Statement  

  

Suppose you want to add incentive from another sheet in the Salary Sheet, Incentive 

worksheet consists of an incentive table whose range is A1:B12   

  

• Select the cell, where you want the result.  

• Click on Insert Function –Select the Vlookup () function from Lookup and Reference 

category.  

• Lookup Value – Select A2 [The Employee code]  

• Table Array: Select the Incentive Sheet and Select the Range from $A$1:$B$12 [i.e. 

Employee code and incentive Column]  

• Column Index: Type 2 [Column 2 is the Incentive column in Incentive table ]  

• Range Lookup: Type False [we are searching the exact match from the table for the 

lookup value]  

  

Note: To remove #NA, you can use the function Iserror. The Syntax of iserror is as 

follows:   

         =if(iserror(vlookup….),‖‖,Vlookup)  
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Example of Vlookup with True Statement  

  

Suppose you want to add incentive Value based on Slab-wise, instead of If condition you 

can use can use Vlookup with True condition. Suppose if we take example based on 

salary give the incentive value, so crate a table as given below, and in table array select 

the table given below and range lookup type true instead of false.  

  

  

0  

  

2%  

5000  5%  

10000  10%  

15000  15%  

  

Note: the Table slab should be in ascending order.  

Database functions  

  
Database functions are used to perform totals or subtotals on the data in the table. The 

functions have 3 arguments — database, field, and criteria.  

  

• The database argument is the range that contains your list. You must include the row 

that contains the column labels in the range  

• The field argument is the label for the column you want to summarize.  

• The criteria argument is the range that contains a condition you specify.  

Dsum  

  

It sums up the values in a column of a list or database that match conditions you specify   

  

Syntax  

  
Dsum (database, field, criteria)  

  

Examples  

  

The following illustration shows a database of Employee Information System, if you want 

to find the Total Salary of employees from Mktg Dept of the East Region, you can use 

the function Dsum.  
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Note: The Advantage of using Dsum is if you change the condition from Mktg to Finance 

criteria then you will get the result of given condition.  

  

  

  
  

DSUM (Database,‖salary‖a1:b2). This function calculates the total Salary for Region East 

and Mktg Dept.  

  

DCOUNT (Database,‖salary‖a1:b2)). This function counts the no of employee those who 

are in East Region and in Mktg Dept.  

   

DMAX (Database,‖salary‖a1:b2)). This function calculates for the Maximum Salary paid 

in Region East and in Mktg Dept.  

  

DMIN (Database,‖salary‖a1:b2)). This function calculates for Minimum Salary paid in 

Region East and in Mktg Dept.  

  

DAVERAGE (Database,‖salary‖a1:b2). This function calculates Average Salary paid in 

Region East and in Mktg Dept.  

Financial Functions  
PMT  

  

Calculates the payment for a loan based on constant payments and a constant interest rate.  
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Syntax  

  
PMT(rate,nper,pv,fv,type)  

  

• Rate   is the interest rate for the loan.  

• Nper   is the total number of payments for the loan.  

• Pv   is the present value, or the total amount that a series of future payments is worth 

now; also known as the principal.  

  

  A  B  

1  Loan Amount  100000  

2  Interest rate   8.50%  

3  Period                   36  

  EMI  =pmt(b2/12,b3,b1)  

  

Steps to calculate PMT  

  

Click on Insert menu, Click on Function, Select Financial from Select a Category box 

Select a PMT function in it.    

Enter Rate as cell B2/12 or 8.5%/12, Nper as cell B3 or 36 and Pv as cell B1 or 100000 in 

respective fields. Click on OK button.  

FV  

  

Returns the future value of an investment based on periodic, constant payments and a 

constant interest rate.  

Syntax  

  
FV(rate,nper,pmt,pv,type)  

  

Rate   is the interest rate per period.  

Nper   is the total number of payment periods in an annuity.  

Pmt   is the payment made each period; it cannot change over the life of the annuity. 

Typically, pmt contains principal and interest but no other fees or taxes. If pmt is omitted, 

you must include the pv argument.  

Pv   is the present value, or the lump-sum amount that a series of future payments is 

worth right now. If pv is omitted, it is assumed to be 0 (zero), and you must include the 

pmt argument.  

Type   is the number 0 or 1 and indicates when payments are due. If type is omitted, it is 

assumed to be 0.  

  

Example of FV:  
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Suppose a person wants to open a saving account in a bank with an initial deposit of 

Rs.10000 and Rs.200 as monthly deposit, for a period of 5 years at 5% rate of interest. 

What will be the amount incurred by the person after 5 years?  

Enter the following data in your worksheet and find the future value on an investment.  

  

  C  D  

5  Rate Of interest  5%  

6  Period in yrs  5  

7  Payment /month   -200  

8  Initial Deposit   -10000  

9  Future Value  =FV( d5/12,d6*12,d7,d8)  

  

Data Validation  
  

Data Validation is a process which restricts the users from entering invalid data for 

individual cells or cell ranges; restricts the data entry to a particular type, such as whole 

numbers, decimal numbers, or text; and sets limit on valid entries.  

  

  
  

Designate valid cell entries  

  

Select the cell to validate.   

On the Data Tab, click Validation, from the Data Tool Group and then click the Settings 

tab.   

Specify the type of validation you want:   
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1. Allow values from a list  

  

This Validation allows the user to pickup the data from the 

dropdown, where the source will be in different cell, or to define the 

list locally, type the list values separated by commas.   

  

Steps are as follows  

1. Select a blank cell   

2. Select DataTab  

3. Select Data Validation from Data Tool Group  

4. Select List  

5. In Source, select the cell with value, or type the data with comma.  

  

If the Source is from different sheet, create the name of the values, and use name by 

typing the equal sign (=) followed by the name of the range.   

  

2. Allow numbers within limits  

  

• In the Allow box, click Whole Number or Decimal.  

• In the Data box, click the type of restriction you want. For example, to set upper and 

lower limits, click between.  

• Enter the minimum, maximum, or specific value to allow.  

  

3. Allow dates or times within a timeframe  

  

• In the Allow box, click Date or Time.  

• In the Data box, click the type of restriction you want. For example, to allow dates 

after a certain day, click greater than.  

• Enter the start, end, or specific date or time to allow.  

  

4. Allow text of a specified length  

  

• In the Allow box, click Text Length.  

• In the Data box, click the type of restriction you want. For example, to allow up to a 

certain number of characters, click less than or equal to.  

• Enter the minimum, maximum, or specific length for the text.  

  

5. Calculate what's allowed based on the content of another cell  

  

• In the Allow box, select the type of data you want.  

• In the Data box, select the operator(for criteria) you want.  

• In the box or boxes below the Data box, click the cell that you want to use to specify 

what's allowed. For example, to allow entries for an account only if the result won't 
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go over the budget, click Decimal for Allow, click less than or equal to for Data, 

and in the Maximum box, click the cell that contains the budget amount.  

  

6. Use a formula to calculate what's allowed  

  

• In the Allow box, click Custom.  

• In the Formula box, enter a formula that calculates a logical value (TRUE for valid 

entries or FALSE for invalid). For example, to allow the value in the cell for the 

picnic account only if nothing is budgeted for the discretionary account (cell D6) and 

the total budget (D20) is also less than the $40,000 allocated, you could enter 

=AND(D6=0,D20<40000) for the custom formula.  

  

To display an optional input message when the cell is clicked, click the Input Message 

tab, and make sure the Show input message when cell is selected check box is selected, 

and fill in the title and text for the message.  

  

Specify how you want Microsoft Excel to respond when invalid data is entered: Click 

the Error Alert tab, and make sure the Show error alert after invalid data is 

entered check box is selected.  

  

Select one of the following options for the Style box:  

To display an information message that does not prevent entry of invalid data, click 

Information.  

  

To display a warning message that does not prevent entry of invalid data, click Warning.  

  

To prevent entry of invalid data, click Stop.  

Fill in the title and text for the message (up to 225 characters).  

  

Note: If you don't enter a title or text, the title defaults to "Microsoft Excel" and the 

message to: "The value you entered is not valid. A user has restricted values that can be 

entered into this cell."  

Protecting Workbook   
  

By protecting a worksheet, you can prevent unauthorized users from modifying it. You 

can choose to protect an entire worksheet or to protect a part of it, allowing users to alter 

some cell in worksheet.  

Protecting a worksheet by using passwords  
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You can protect a worksheet by using the Protect Sheet dialog box.  

• Go to Review Tab -> Change Group and select Protect Sheet to open the Protect 

Sheet dialog box.  

• Select the options you want.  

• Enter a password and click OK. A Confirm Password dialog box will appear.  

• Enter the same password in the Reenter password to precede box and click OK.  

  

  
  

Protecting part of a worksheet  

  

When you protect an entire worksheet, all the cells in the worksheet are locked by default. 

This means that users cannot make changes to any cell in the worksheet. To allow the 

users to make changes to particular cells only, you must unlock the cells manually before 

protecting the worksheet. Users can then change data only in the unlocked cells. You can 

hide the formula, so it will be now visible to the user.  

  

To password protect only a part of a worksheet:  

  

Step 1  

  

• Select the range of cells that you want users wants to modify   

• Click on Format, Cells to open the Format Cells dialog box and then activate the 

Protection tab.  

• Clear the Locked check box and click OK  

• Select the range of cells where the formula is applied, Click on Format CellProtection, 

and Select both Locked as well as hidden checkbox.  

Step 2  

  

Now go to Review Tab-> Change Group and select Protect Sheet – Protect sheet and give 

the Password.  
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Built-in templates  
  

A template is a special type of workbook you can use as a starting point for other 

workbooks. Templates can contain labels and other data, formatting, styles, and 

functionality you can use for a particular purpose. Excel provides several built-in 

templates to help you create forms such as invoices, purchase orders, and expense 

statements.  

  

You can view Excel‘s built-in templates by clicking on Office Button->Select New-> 

Templates –Click on My Template  

Creating and managing templates  

  

When Excel does not provide a template that suits your needs, you can create your own 

custom templates. Like built-in templates, custom templates make it easy to create and 

maintain multiple workbooks with the same formatting, styles, content, and functionality.  

Creating and using a template  

  

To create a template:  

Open or create the workbook on which you want to base the template.  

  

• Choose File, Save As to open the Save As dialog box.  

• From the Save as type list, select Template.  

• In the File name box, enter a name for the template.  

• Click Save.  Close the Workbook  

  

Once you create the template Create a new workbook based on the template. Enter the 

remaining information. Save the workbook close it.  

Modifying templates  

  

Sometimes, you might need to modify custom templates. To modify a template, choose 

File, Open to display the Open dialog box; specify the location and the name of template 

file that you want to modify, and click Open. Make the changes you want and update the 

template.  

  

Note: Templates are saved in   

C:\Documents and Settings\User_name\Application Data\Microsoft\Templates.  
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Guidelines for entering data in a worksheet  
  

Microsoft Excel has a number of features that make it easy to manage and analyze data. 

To take advantage of these features, enter data in your worksheet according to the 

following guidelines.  

Data organization  

  

Put similar items in one column (For Ex if Emp Code is in Column A then fill data 

related to Emp Code in Column A)  Format the cells so that all rows have similar items in 

the same column (i.e data related to Employee shall appear in the row) . Keep the range 

separate.   Leave at least one blank column and one blank row between the related data 

range and other data on the worksheet. Excel can then easily detect and select the range 

when you sort, filter, or insert automatic subtotals.  

  

Position the critical data above or below the range, avoid placing critical data to the left or 

right of the range; the data might be hidden when you filter the range. Show rows and 

columns and make sure any hidden rows or columns are displayed before making 

changes to the range. When rows and columns in a range are not showing, data can be 

deleted inadvertently.  

Data format  

  

• Use formatted column labels   Create column labels in the first row of the range of data. 

Excel uses the labels to create reports and to find and organize data. Use a font, 

alignment, format, pattern, border, or capitalization style for column labels that is 

different from the format you assign to the data in the range.   

  

• Format the cells as text before you type the column labels. Use cell borders when you 

want to separate labels from data, use cell borders— not blank rows or dashed lines—  

to insert lines below the labels.  

  

• Avoid blank rows and columns   Avoid putting blank rows and columns in the range so 

that Excel can more easily detect and select the related data range.  

  

• Don't type leading or trailing spaces   Extra spaces at the beginning or end of a cell 

affect sorting and searching. Instead of typing spaces, indent the text within the cell.  
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• Extend data formats and a formula when you add new rows of data to the end of a data 

range; Excel extends consistent formatting and formulas. Three of the five preceding 

cells must use the same format for a format to be extended. All of the preceding 

formulas must be consistent for a formula to be extended.  

About Data lists   

  

A Microsoft Excel list provides features designed to make it easier to manage and analyze 

groups of related data in an Excel worksheet. When you designate a range as a list, you 

can manage and analyze the data in the list independently of data outside the list. For 

example, using only the data contained within the list, you can filter columns, add a row 

for totals, and even create a PivotTable report, using only the data contained within the 

list.  

  

You can have multiple lists on your worksheet, which allows you a great deal of 

flexibility for separating your data into distinct, manageable sets according to your needs.  

  

Note: You cannot create a list in a shared workbook. You must remove the workbook 

from shared use first if you want to create a list.  

  

  
  

• Every column in the list has AutoFilter enabled by default in the header row. 

AutoFilter allows you to filter or sort your data quickly.  

• The dark blue border around the list clearly distinguishes the range of cells that makes 

up your list.  

• The row that contains an asterisk is called the insert row. Typing information in this 

row will automatically add data to the list and expand the border of the list.  

• A total row can be added to your list. When you click a cell within the total row, a 

drop-down list of aggregate functions becomes available.  

• You can modify the size of your list by dragging the resize handle found on the 

bottom corner of the list border.  

  

The benefits of lists  
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Sort and filter lists   you can sort lists in ascending or descending order or create custom 

sort orders. You can also filter lists to show only the data that meets the criteria you 

specify.  

  

Format list objects    You can format cells in a list the same way that you format cells in 

a worksheet.   

  

Sorting and Filtering Data  
  

Performing a Simple Sort  

  

To sort your entire list, just select a single cell in the list and choose the Sort command 

from the Data Tab.  Microsoft Excel automatically selects the whole list for you. If your 

list has column labels in the first row, Microsoft Excel excludes them from the sort and  

uses them to help you choose the Sort by column.  Sort the data Regionwise,  

Department wise in 

ascending order.  

 
If Microsoft Excel does not automatically select the data you want to sort, manually select 

the data and choose the Sort command again.  

  

Rows that contain duplicate items in the Sort by column appear together in the sorted list 

in their original order.  If you want to sort these duplicate rows further, you can specify a 
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second column to sort by clicking on Add Level button in the upper left most corner 

windows. If there are duplicate items in this second column, you can specify a third 

column to sort by in the second Then By box. You can sort by up to 64 columns at a time.  

  

Microsoft Excel saves the sort options you select in the Sort dialog box and Sort Options 

dialog box - such as the Sort By column, sort order (ascending or descending), and sort 

orientation (top to bottom or left to right) - and displays them each time you choose the 

Sort command until you change the options or sort another list.  

Customized Sorting  

  

Suppose if we sort the data region wise, it sort either ascending or descending order, if 

you want to sort your data in a customized order, for Example West, East, North, and 

South   

  

  

First we need to create a custom list as we want to sort,  

Steps  

• In Excel 2010, open File and go to Options.  

  

• Select the Advanced option and on right pane, scroll down till you see Edit 

Custom Lists button.  

http://www.ihaveapc.com/wp-content/uploads/2011/07/excellist0.png
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• Hit the Edit Custom Lists button and select NEW LIST.  

  
• Enter a list of items on the right side as shown (in this example, computer names 

like Apache, Comanche and Dragonfly).  

• Hit the Add button, the entered items should show up as comma separated just 

like the lists above it.  

Once this custom list is created, in order to use it anywhere in Excel 2010, simply enter 

the name of any item from the list and drag the mouse cursor as desired, this will fill the 

other cells with the remaining items from the custom list.  

http://www.ihaveapc.com/wp-content/uploads/2011/07/excellist1.png
http://www.ihaveapc.com/wp-content/uploads/2011/07/excellist2.png
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This is quite a convenient feature especially when lots of data crunching is to be done. 

Defining various Excel custom lists of commonly used items of a list and using them as 

and when required becomes a time saver.  

Sort the Excel List in Custom Order  

To sort your list based on your custom list, follow these steps:  

1. Select a cell in the table that you want to sort.  
2. On the Ribbon’s Data tab, click Sort  
3. In the Sort dialog box, select a Column from the first drop down, and select Values 

from the Sort On drop down.  

  

    

http://www.ihaveapc.com/wp-content/uploads/2011/07/excellist3.png
http://www.ihaveapc.com/wp-content/uploads/2011/07/excellist4.png
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4. In the Order drop down, click Custom List  
5. In the Custom List dialog box, select your custom list, and click  OK  
6. Click OK to close the Sort dialog box  

The list is sorted in the order of the items in your custom list.  

  

Filtering a List  

  

In Excel Spreadsheet if you want to track the sales information or salary information in 

existing data, or often want to extract the salary details base on some condition , in such 

scenario Excel has given a command known as Filter.  

  

Auto Filter enables you to display a subset of your list with a click of a mouse button.  

When you choose the Filter icon from the Data Tab, Microsoft Excel places drop-down 

arrows directly on the column of your list. Clicking an arrow displays a list of all the 

unique items in the column.  By selecting an item from a list for a specific column, you 

can instantly hide all rows except that row that contain the selected value and its related 

information (that complete row).  

  

The item you select in a column drop-down list is called the filter criterion. For example, 

selecting East from the Region drop-down list hides all rows except those that contain 

region east. You can filter your list further by choosing another criterion from another 

column.  For example, selecting Mktg from the Dept drop-down list also hides all rows 

except those that contain East and Mktg Dept. In some case if you want to select the 

multiple regions i.e. East and West in such case you have to select the custom from dept 

drop down.  
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Tip:   If the list of items is long, you can quickly move to an item by selecting the arrow, 

then typing the first letters of the item.  

  

When you hide rows using criteria, you are applying a filter to a list.  Microsoft Excel 

helps you recognize the filter status of a list by providing some visual cues.  

Filtering a List using Advanced Filter  
  

To filter a list using more complex criteria i.e. when we have condition like for e.g., 

display the details of employees who earn between greater than 3000 and less than 5000 

or between 10000 to 15000, those who are in East or North Region in such case you can‘t 

retrieve the condition using simple filter. In such case you have to use Advance Filter 

(Data Tab ->Advance Filter icon).  

  

Here besides having a data in tabular format, we have to also specify the condition to be 

met in a different area of a worksheet. For a clearer picture refer the following e.g.  

  

  
  

The Advanced Filter command filters your list in place, as simple Filter does, but it does 

not display drop-down lists for columns. Instead, you have to select the List Range i.e. 

your data, type criteria in a criteria range on your worksheet and select the Criteria 

Range and in output range type the cell address where you want to display the output. It 

is optional.  

Filtering unique records  

  

• Select the column or click a cell in the range or list you want to filter.   

• On the Data Tab, point to Filter, and then click Advanced Filter.   

• Do one of the following.   

  

To filter the range or list in place, similar to using AutoFilter, click Filter the list, inplace.   

To copy the results of the filter to another location, click Copy to another location. Then, 

in the Copy To box, enter a cell reference.   
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 To select a cell, click Collapse Dialog to  temporarily hide the dialog box. Select the    

cell on the worksheet, and then press Expand Dialog .  

• Select the Unique records only check box.   

  

Note: Advanced filter, copy to Option copies on a same worksheet, if you want to copy 

the Filter data in to different worksheet, and then select the Advanced Filter command 

from a new worksheet.  

Grouping Data Using Subtotals  
  

If you want to summarize the salary details according to region wise, you display 

automatic subtotals by selecting a single cell in the list and choosing the Subtotals 

command from the Data menu.  Microsoft Excel uses the column labels to help you 

identify the items you want grouped and the values you want summarized.  

Display Subtotal at Single Level  

  

For performing Subtotal on data, first the table fields on which subtotal are done must be 

sorted. After you click the subtotals command from the Data Tab->Outline Group, select 

the desired column from At Each Change In list box then select the function which you 

want to perform on data from the Use function list box then select the column on which 

you want to perform subtotals from the Add Subtotal to field. When you choose the OK 

button, Microsoft Excel inserts a subtotal row for each group of identical items in the 

selected column.   

  

  
  

Choosing a Summary Function  
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The first time you use the Subtotals command for a list, Microsoft Excel suggests a 

summary function based on the type of data in the column you select in the Add Subtotal 

To box, Choose a different calculation, such as Average, by selecting a different 

summary function in the Use Function box in the Subtotal dialog box.  

  

Choosing the Values to Summarize  

  

The first time you use the Subtotals command; the Add Subtotal To box displays the label 

of the right-most column. You can leave that label as your selection, or you can select the 

label of any other column in the list. The next time you use the Subtotals command, 

Microsoft Excel displays the label of the last column you selected.  

  

  

  

  

Displaying Subtotal Rows above the Detail Data  

  

If you want your subtotal rows to appear above their associated detail data, and if you 

want the Grand Total row to appear at the top of the list, clear the Summary below Data 

check box in the label of the end of the list to see grand total data.  

  

  

  

Displaying Nested Subtotals   

  

You can insert subtotals for smaller groups within existing subtotal groups; For example, 

you can insert subtotals for each type Dept in a list that already has subtotals for each 

Region wise.  
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Note: If you want to copy only the summary details then select the outline2 select the 

column, press Alt; that will select only visible cell] and then copy and paste it.  

  

Using add-ins - Conditional Sum Wizard  
  

Add-ins is additional programs that provide custom commands and functions. You can 

load add-ins such as the Conditional Sum Wizard and the Lookup Wizard by using the 

Add-Ins command on the Tools menu.  

Conditional Sum Wizard  

  

The Conditional Sum Wizard helps you generate a formula that adds the values matching 

a condition you specify. Here‘s how:  

  

Choose Tools, Conditional Sum to start the Conditional Sum Wizard. In the Step 1 dialog 

box, specify the range containing the data, including the column headings. Click Next.  

In the Step 2 dialog box, specify the column containing the values to add and the criterion 

to be used for the conditional sum. You can specify a condition by using the three 

available lists: Column, Is, and This value. Click Add Condition and then click Next. In 

the Step 3 dialog box, specify whether you want to insert only the result or both the result 

and the condition. Click Next.  

In the Step 4 dialog box, specify the cell where you want the result to appear, and then 

click Finish.  

  

  

Select the column for Nested  

Subtotal   

Clear Replace current subtotals   

checkbox while displaying  

Nested Subtotal   
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Creating PivotTables  

 
  

PivotTable reports (or, simply PivotTables) make the data in your worksheets much more 

manageable by summarizing the data and allowing you to manipulate it in different ways. 

PivotTables can be an indispensable tool when used with large, complex spreadsheets, 

but they can be used with smaller spreadsheets as well.  

  

A pivot table is an interactive worksheet table that quickly summarizes large amounts of 

data using the format and calculation methods you choose.  It is called a pivot table 

  

  



ADVANCE EXCEL | PROFF.GAYATRI SHETH 

 

P a g e  40 | 80 

 

because you can rotate its row and column headings around the core data area to give you 

different views of the source data.  As source data changes, you can update a pivot table.  

Because it resides on a worksheet, you can integrate a pivot table into a larger worksheet 

model using standard formulas.  

Steps to Create a Simple Pivot Table   

  

You create a pivot table using the Pivot Table Wizard. The Pivot Table Wizard is an 

interactive set of dialog boxes that guide you through the steps of choosing the source 

data and layout you want to use for the pivot table.  

Start the Pivot Table Wizard   

  

A Pivot Table is an interactive table that summarizes and analyses data from existing lists 

and tables. Use the PivotTable Wizard to specify the list or table you want to use and to 

define how you want to arrange the data in the PivotTable. After you create a PivotTable, 

you can reorganize the data by dragging the fields and items. When you base a 

PivotTable on external data, you may want to retrieve the external data before you create 

the PivotTable.  

  

• Open the workbook where you want to create the PivotTable. If you are basing the 

PivotTable on a Microsoft Excel list or database, click a cell in the list or database.  

• On the Insert Tab ->Table Group, click PivotTable  

• Select the data source range  

• If you are inside database, it automatically picks the range  

• Then decide where you want to place your PivotTbale report, i.e. in same sheet or 

different sheet  

• Click OK  
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• Once you click OK the screen shown below:  
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• Drag the fields you want to use as row field and column field labels into the Row and 

Column areas.  

• The more fields you include in an area, the finished pivot table contains more fields. 

Adding two fields to the Row area adds two row fields to the pivot table.  

• By moving the Dept field to the Report Filter area, you create a pivot table that 

displays data for one particular Dept at a time. (Dept wise report is generated. If there 

is any date/month field, a date-wise report could be generated.). It is mandatory to 

place any one of the fields into the VALUE area.  

• If a numeric field is placed by default, it calculates the total of that field, else any 

other text/date/ character field is placed, and then the count of it will be displayed at 

the end of report. If you don‘t specify any field in this area, wizard won‘t allow you to 

proceed to the next step.  
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How to Save Data with the Pivot Table Layout  

  

When you create a pivot table, Microsoft Excel stores a copy of the source data as hidden 

data with the pivot table layout on the worksheet.  If you have a large amount of data and 

you do not want to store a copy of it with the pivot table, clear the Save Data with Table 

Layout by following.  

  

• Right click your mouse on report area  

• Click PivotTable Options  

• Click Data Tab  

• And then check off-> save source data with file  

   

Output  

  

  
  

Updating a Pivot Table  
  

If you change data in the source list of table, you can update or refresh the pivot table 

without recreating it. Most changes you make to the source data can be quickly displayed 

in the pivot table using the Refresh Data command on the Option Tab -> Data Group, or 

by right clicking mouse on report area and then refresh option. You can set certain 

interval in the terms of minutes for auto refresh, if your report is based on external data 

source.   

Format a PivotTable report  

Click on Design Tab ->PivotTable Styles Group –>select either design/style or go for 

New PivotTable Styles  
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Calculate the Percentage of the field   

  

In the report layout go to Value area and then click down arrow key of field for which 

you want the Percentage,   

  

 

  

  

 Click Show value as tab and the click Show value as drop down list box  

Select the % of total from show data a  

Group items in a PivotTable  

  

If you want to generate a report on Year wise Quarter wise based on 

existing data you have for such scenario you can use a group option in  

Pivot Table  

  

Group date field  

  

• Right-click the field with the dates or times, clicks on Group   

• Enter the first date or time to group in the Starting at box, and enter the last date or 

time to group in the Ending at box.   

• In the By box, click one or more time periods for the groups.   

  

  

If you have grouping on date field, you can group items by weeks, click Days in the By 

box, make sure Days is the only time period selected, and then click 7 in the Number of 



ADVANCE EXCEL | PROFF.GAYATRI SHETH 

 

P a g e  45 | 80 

 

days box. You can then click additional time periods to group by, such as Month, if you 

want.  

Create a chart from data in a PivotTable report  

  

Create a Graph using Pivot Data  

  

• From inside report press F11 function key  

• Or Click Pivot chart from Option Tab ->Tools Group  

  

The Graph will be created based on the pivot table. You have drop down to select the 

graph according to condition wise.  

What-if-Analysis Tools  
  

If you have created a formula to calculate PMT, base on the formula, if you want to know 

in if you pay x amount of value in how many months you can complete the installment  

  

The Goal seek Feature in Excel helps us to compute a value for the spreadsheet input that 

makes the value for the given formula match the goal you specify. Goal Seeking saves 

you from performing time-consuming trial-and error analysis.  

Using the Goal Seek Command  
  

To find a specific value that solves a formula, select the cell containing the formula.  

Then choose Goal Seek from the Data Tab ->Data Tools Group ->What-If Analysis 

>Goal Seek.  

  

Select the reference or name of the cell containing the formula for which you want to find 

a specific solution if it is not displayed in the Set Cell option of the Goal seek dialog box. 

(Assuming that we have started from cell A1, select the address of selling price value i.e., 

B3).  

  

Type the value that you want the formula to reach in the To Value option i.e.,-5000 Select 

the reference or name or the cell containing the variable that you want to adjust for the 

goal to be attained i.e., B2 address of the cost price value.  

  

E.g., If a person takes a Loan of 100000 for 36 Months the EMI [PMT] is 3250, if he pays 

monthly 5000 then in how many months he will complete his installment.  
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Goal-Seeking Guidelines  

  

• You can enter either cell references or names in the Set Cell and By Changing Cell 

boxes.  

• The address in the Set Cell box must be directly or indirectly a formula.  

• A changing cell must contain a value that the formula in the Set Cell box depends on, 

either directly or indirectly.   

• A changing cell cannot contain a formula.  

• While goal seeking proceeds, the Goal Seek Status dialog box appears on the screen.  

To interrupt the operation, choose the Pause button.  

• If you want to continue one step at a time after choosing the Pause button, choose the 

Step button to resume normal operation.  

• When goal seeking is complete, Microsoft Excel displays the results on the worksheet 

and in the Goal Seek Status dialog box. Choose the OK button to keep the solution 

values on the worksheet; choose the Cancel button to restore the original values.  

• If you decide to keep the solution on the worksheet but then change your mind, 

choose Undo Goal Seek from the Edit menu immediately after goal seeking is 

complete.  

  

Projecting Figures Using a Data Table   
  

Most of the spread sheet models contain assumption about certain parameters or input to 

the model, or based on different cost price and selling price what will be the profit.  

  

Once you've entered formulas on your worksheet, you can perform a "what-if" analysis 

using a data table to see how changing certain values in your formula affects the results 

of formulas.  A data table is a range of cells that show the results of substituting different 

values in one or more formulas.  Data tables provide:  

  

• A shortcut for calculating multiple variations in one operation.  
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• A way to view to and compare the results of all of the different variations together on 

your worksheet.  

  

There are two types of data tables.  

  

One-Input Data Table: You enter different values for one variable and see the effect on 

one formula.  

Using a One-Input Data Table   

  

To see how changes in one variable affect one or more formulas, use a one-input data 

table.  The data table in the following illustration is set up so that the interest rates entered 

in column B-the input values-are substituted in cell D5-the input cell. The resulting 

monthly payments are entered in the cell below the formula in cell C11.  

  

  D  E  

5  5  Years  

6  10.5%  Rate  

7  100000  amt.  

  

Cell C11 contains the formula=PMT(D6/12,D5*12,D7) that calculates the monthly 

payments using the input cell D5.  

  

First, select the rectangular range containing the formula and the input values (B11:C16).    

  

  

  

The Column B gives the number of years 

you want to calculate the PMT for. When 

you choose Table from the Data Tab -

>Data Tools Group ->What-If Analysis, 

specify cell D5 as the Column Input Cell.  

  

  B  C  

11    (Rs2,149.39)  

12  1   

13  2   

14  3   

15  4   

16  5   
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As soon as we click on OK we get the following result as shown in figure below.  

  

  B  C  

11    (Rs2,149.39)  

12  1  -8814.86029  

13  2  -4637.60416  

14  3  -3250.24435  

15  4  -2560.33798  

16  5  -2149.39004  

  

  

Adding Formulas or input Values to an Existing Data Table   

  

You can use as many formulas and input values, as you need in a one-input data table.  

However, each formula must directly or indirectly refer to the same input cell. To add 

additional formulas or input values to a data table, enter them in the blank cell below or 

to the right of the existing formulas. Then select the entire table and modify it using the 

Table command on the Data Tab ->Data Tools Group ->What-If Analysis.  

  

In the preceding illustration, for example, you can also enter a formula in cell D11 that 

calculates total interest paid on the loan.  First, select the rectangular range containing 

both the formulas and the input values, as shown in the following illustration.  Then 

specify cell D5 as the column-input cell. After you choose the OK button, the new values 

are added to the table under cell D11.  

  

  

  

Row Input Values versus Column Input Values   

  

In addition to entering input values in a column, as shown in the preceding example, you 

can also enter input values in a row across the top of the table and enter formulas on the 

side of the table.  With this layout, you specify a Row Input Cell in the Table dialog box.  

Using a Two-Input Data Table  
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To see how changes in two variables affect one formula, use a two-input data table. You 

can include a number of values for each of the two variables, but you can use only one 

formula in a two-input data table.  

Look at the following Table  

  

  D  E  

5  5  Years  

6  10.5%  Rate  

7  100000  amt.  

  

In the following illustration, fill up the table as shown in the figure below. The figure 

shows we have filled in 11th row rate of Interest and in the Column B from b12:b16 

Period. The cell B11 contains the formula =ABS(PMT(D5/12,D6,D7))  

  

  B  C  D  E  

11  (Rs2,149.39)  5%  6%  7%  

12  12       

13  24       

14  36       

15  60       

16  120       

  

When you choose Table from the Data Tab ->Data Tools Group ->What-If Analysis, 

specify cell D5 as the Column Input Cell (as Years are in Column). And cell D6 as Row 

Input Cell (as Rate of Interest is in Rows).  

  
  

Click on the OK button.  

  

  

The Table command calculates these values and adds them to your worksheet.  

  

C  B  C  D  E  

11  (Rs2,149.39)  5%  6%  7%  
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12  1  -8560.75  -8606.64  -8652.67  

13  2  -4387.14  -4432.06  -4477.26  

14  3  -2997.09  -3042.19  -3087.71  

15  4  -2302.93  -2348.5  -2394.62  

16  5  -1887.12  -1933.28  -1980.12  

What-If Scenarios   
  

Scenarios are part of a suite of commands sometimes called what-if analysis tools. A 

scenario is a set of values that Microsoft Excel saves and can substitute automatically in 

your worksheet. You can use scenarios to forecast the outcome of a worksheet model. 

You can create and save different groups of values on a worksheet and then switch to any 

of these new scenarios to view different results. You can define up to 32 changing cell 

per scenario.  

  

You can use the Scenario Manager to:  

  

• Create multiple scenarios with multiple sets of changing cells.  

• View the results of each scenario on your worksheet.  

• Create a summary report of all input values and results.  

• Merge scenarios from a group into a single scenario model.  

• Protect scenarios from modification and hide scenarios.  

• Keep track of modifications with an automatic scenario history.  

  

  

Creating scenarios  For example, if you want to find a Net Income on different scenario 

in given example.  

  

   1999  

Sales  54500  

Other Income  28000  

Gross Income  82500  

Expense     

Tel. Exp  3264  

Tra. Exp  3570  

Mis. Exp  2537.5  

Total Exp  9371.5  

      

Net Income  73128.5  

  

   
Current 

Scenario  
Best  
Scenario  

Worst  
Scenario  

Sales  9%  13%  5%  
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Other Income  12%  18%  8%  

Tel. Exp  2%  3%  5%  

Tra. Exp  2%  4%  5%  

Mis. Exp  1.50%  1.50%  1.50%  

  

Create a scenario  

• Go to Data Tab ->Data Tools Group ->What-If Analysis ->Scenario Manager  Click 

Add.   

• In the Scenario name box, type a name for the scenario.   

   

  
  

  

  

• In the Changing cells box, enter the references for the cells that you want to change. 

[eg select the range of current scenario range]  Click OK.   

• In the Scenario Values dialog box, type the values you want for the changing cells.   

• To create the scenario, click OK.   

• If you want to create additional scenarios, click Add again, and then repeat the 

procedure. When you finish creating scenarios, click OK.   

Create a scenario summary report  

  

• Go to Data Tab ->Data Tools Group ->What-If Analysis ->Scenario Manager  Click 

Summary.   
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• Click Scenario summary or Scenario PivotTable.   

• In the Result cells box, enter the references for the cells that refer to cells whose 

values are changed by the scenarios. Eg [ Net Income in the above example]. Separate 

multiple references with commas.   

Delete a scenario  

 Go to Data Tab ->Data Tools Group ->What-If Analysis ->Scenario Manager   

Click the name of the scenario you want to delete, and then click Delete.  

Display a scenario  

  

When you display a scenario, you change the values of the cells saved as part of that 

scenario.  

  

• On the Tools menu, click Scenarios.   

• Click the name of the scenario you want to display.   

• Click Show.   

  

Tip: Double-clicking the name of the scenario displayed in the Scenarios box is the same 

as selecting the name and choosing the Show values.  

  

Merge scenarios from another worksheet  

  

It is easier to merge scenarios when all what-if models on the worksheets are identical. 

All changing cells on the source worksheet must refer to the corresponding changing cells 

on the active worksheet. Microsoft Excel copies all scenarios on the source sheet to the 

active worksheet.  

  

Open all of the workbooks that contain the scenarios you want to merge.  Switch 

to the worksheet where you want to merge the scenarios.   

  

• Go to Data Tab ->Data Tools Group ->What-If Analysis ->Scenario Manager   

Click Merge.   

• In the Book box, click a workbook name.   

• In the Sheet box, click the name of a worksheet that contains the scenarios you want 

to merge, and then click OK.   

Repeat this process if you want to merge scenarios from more worksheets.   
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Protecting Scenarios  

  

The Add Scenario and Edit Scenario dialog boxes contain two protection options: Prevent 

Changes and Hide. If you select Prevent Changes and then activate sheet protection, the 

scenarios you define cannot be edited.  However, this does not prevent you from the 

values of the changing cells directly on the sheet  (unless the cells themselves are locked).   

Rather, the scenarios themselves are protected from modification when the Prevent 

Changes check box is selected. In addition, selecting the Hide check box removes a 

scenario name from the list of defined scenarios, preventing its display.  

  

Once you select protection options in the Add Scenario or Edit Scenario dialog box, you 

must activate sheet protection. To do this, use the protection command on the Tools 

menu, and then choose Protect Sheet.  

  

Note:  When sheet protection is activated, you can still add scenarios.  However, you 

cannot edit or delete them unless the Prevent Changes check box is cleared.  

   

Using multiple worksheets  

  

Linking worksheets by using 3-D formulas  

  

Excel formulas can refer to cells and ranges in other worksheets within a workbook. They 

can   also refer to cells or ranges on a range of worksheets.  

  

3-D formulas  

  

A 3-D formula references the same cell or range on multiple worksheets. For example, 

the formula = Jan!b2+Feb!b2+March!b2 will sums the data from the different worksheet 

range. The syntax for referring to cells in another worksheet is:  

  

worksheet_name!reference  

  

Here, worksheet_name, refers to the name of the worksheet that provides the data, 

reference is the name of the cell or range, and ! is the divider between the worksheet 

reference and the cell reference.  

  

To insert a 3-D reference in a formula:  
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• Begin to enter your formula or function up to the point of needing a reference or an 

argument.  

• Activate the tab for the first worksheet to which you want a reference.  

• While holding the Shift key, activate the tab for the last worksheet you want to 

reference.  

• Select the cell or range of cells you want to reference.  

• Complete and enter the formula or function.  

  

Consolidating Data  

  

Consolidation means collecting data which is scattered in different workbooks or 

worksheets. To consolidate data, you combine the values from several ranges of data. For 

example, if you have a worksheet of sales figures for each of your regional offices, you 

might use a consolidation to roll these figures into a corporate sales worksheet.  

  

If we have a sheet consisting sales figure for different products for each month like Jan, 

Feb and March. Suppose we want to find quarterly sales i.e. total sales of the first three 

months. In such cases, we can consolidate the three worksheets and get a summary of the 

same. Let‘s see how we do it.  

  

Assuming we have data in three sheets:  

  

Jan Sheet          Feb Sheet  

            

 

Product  Amount  

Coca-Cola  125000  

Pepsi  57000  

Sprite  45781  

Thumps Up  80000  

Feb Total  307781  
 

 

Product  Amount  

Coca-Cola  125000  

Pepsi  45000  

Sprite  7800  

Thumps Up  16000  

Jan Total  193800  
 

  

March Sheet        Qtr Sheet  

  

 

Product  Amount  

Coca-Cola  45050  

Pepsi  48000  

Sprite  78005  

Thumps Up  450016  

Mar Total  621071  
 

 

Product  Amount  

Coca-Cola  295050  

Pepsi  150000  

Sprite  131586  

Thumps Up  546016  
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In a new sheet, Click on Data Tab ->Data Tools Group ->Consolidate. The consolidate 

dialog box will open.  

  

  
  

Select the function from the function drop down menu.  

  

In the Reference option, click on the small red arrow and select the Jan. total. Click 

on Add.  

  

• Similarly select the range for Feb. and March and click on 

Add.  In the Use Labels In option select the option Left column.  

• Select the option Create links to source data. Then click on 

OK.  The consolidated data will be displayed on the new sheet 

(Qtr)  

Creating Hyper Link  
  

Creating links within the same sheet  

  

To link a particular cell, first define name to the cell.  

  

• Select the cell, go to Formulas Tab ->Define Names Group -> Define Name. The 

define name dialogue box will appear. In the define dialogue box type a name for the 

cell and click on Add. Click on Close.  

• Now click on the cell where the hyper link is to be created and Click on Insert- 

Hyperlink or press Ctrl+K.  
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• The Insert Hyperlink box will appear. Click on the Browse button of the ‗Named 

Location in file‘ option.  

• In the browse dialog box click on the option Defined name the defined names for the 

workbook will appear. Select the defined name, which we created in the above step 

and click on OK.  

• The selected name will appear in the ‗Named Location in file option. Click on OK.  

The link is created.  

Creating links between different worksheets.  

  

To link a particular cell, first define name to the cell.  

• Select the cell, Formulas Tab ->Define Names Group -> Define Name. The define 

name dialogue box will appear. In the define dialogue box type a name for the cell 

and click on Add. Click on Close.  

• Now click on the cell where the hyper click is to be created and Click on Insert- 

Hyperlink or press Ctrl+K.  

• The Insert Hyperlink box will appear.  

• Click on the Browse option of the ‗Link to file or URL‘ option and select the 

workbook for which the cell is to be linked.  

• Then in the next option i.e. ‗Named Location in file‘ click on browse.  

• In the browse dialog box click on the option Defined name the defined names for the 

workbook will appear. Select the defined name, which we created in the above step 

and click on OK.  

• The selected name will appear in the ‗Named Location in file‘ option. Click on OK.  

The link is created.  

Creating links between different software  

  

Let's assume we have to copy a certain data from an excel sheet to the Word document .If 

you do a normal copy-paste the contents pasted in the Word document are static i.e. they 

will not be updated even if there is a change of data in the excel worksheet. Now let's see 

how to create a link so that the data is updated even in the Word document.  

  

• Copy the contents from the Excel worksheet.  

• While pasting in a Word document click on Edit-Paste special  

• In the Paste Special dialog box select the option Paste Link and click on OK  

  

Now whenever the data in the excel worksheet in changed the change will be 

automatically reflected in the word document.  
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Data Form  
  

Excel can generate a built-in data form for your range. The data form displays all of your 

column labels in a single dialog box, with a blank space beside each label for you to fill 

in data for the column. You can enter new data; find rows based on cell contents, update 

existing data, and delete rows from the range.  

  

Use a data form when a simple form listing the columns is sufficient and you don't need 

more sophisticated or custom features. A data form can make data entry easier than 

typing across the columns when you have a wide range with more columns than will fit 

on the screen at one time.  

  

Use a data entry form to edit a range or list  
  

A data form is a dialog box that gives you a convenient way to enter or display one 

complete row of information, or record, in a range or list at one time.  

Before you can use a data form to add a record to a new range or list, the range or list 

must have labels at the top of each column. Microsoft Excel uses these labels to create 

fields on the form.  

  

Like Excel 2003, Form option/command is not available anywhere. The reason is that the  

Form option is not available on any of the ribbon tabs. To use the form capabilities of 

Excel, you'll need to add the option to the Quick Launch Toolbar by following these 

steps:  

1. Click the File->Options. The Excel Options dialog box appears.  

2. At the left side of the dialog box, click Customize.  

3. Using the Choose Commands From drop-down list, choose Commands Not in the 

Ribbon.  

4. Scroll through the list of commands and select the Form command.  

5. Click the Add button. The Form command now appears at the right side of the 

dialog box.  

6. Click OK. The Form command now appears on the Quick Access Toolbar.  
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Add a record  

• Click New.   

• Type the information for the new record.   

• When you finish typing data, press ENTER to add the record.   

• When you finish adding records, click Close to add the new      Record and close the 

data form.  

Modify a record  

  

Find the record you want to change.   

  

To move through records one at a time, use the scroll bar arrows in the dialog box. To 

move through 10 records at a time, click the scroll bar between the arrows.   

To move to the next record in the range or list, click Find Next. To move to the previous 

record in the range or list, click Find Previous.   

  

To set search conditions, or comparison criteria, click Criteria, then enter the criteria into 

the data form. To find records that match the criteria, click Find Next or Find Previous. 

To return to the data form without searching for records based on the criteria you 

specified, click Form.   

  

Wildcard characters you can use as criteria  

  

The following wildcard characters can be used as comparison criteria for filters, and 

when searching and replacing content.  
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 Use         To find  

Any single character  

For example, sm?th finds "smith" and  

? (question mark)  

"smyth"  

  

* (asterisk)  

Any number of characters  

For example, *east finds "Northeast" and 

"Southeast"  

~ (tilde) followed by ?, *, 

or ~  

A question mark, asterisk, or tilde 

For example, fy91~? finds "fy91?"  

  

Change the information in the record.  
  

• Fields that contain formulas display the results of the formula as a label. The label 

cannot be changed in the data form.   

• If you change a record that contains a formula, the formula is not calculated until 

you press ENTER or click Close to update the record.   

• To move to the next field, press TAB. To move to the previous field, press 

SHIFT+TAB.   

• When you finish changing data, press ENTER to update the record and move to 

the next record.   

• When you finish changing records, click Close to update displayed record and 

close data form.   

Delete a record  

  

• Find the record you want to delete.  

• To move through records one at a time, use the scroll bar arrows in the dialog box. To 

move through 10 records at a time, click the scroll bar between the arrows.   

• To move to the next record in the range or list, click Find Next. To move to the 

previous record in the range or list, click Find Previous.   

• To set search conditions, or comparison criteria, click Criteria, then enter the criteria 

into the data form. To find records that match the criteria, click Find Next or Find 

Previous. To return to the data form without searching for records based on the 

criteria you specified, click Form.   

  

Wildcard characters you can use as criteria  

  

• Click Delete.  
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Notes  
  
• Data forms can display a maximum of 32 fields at one time.   

• While you are adding or changing a record, you can undo changes by clicking Restore 

as long as the record is the active record in the data form  

  

Auditing features  
  

You can use Excel‘s auditing features to trace errors in a worksheet. You can also trace 

the relationships between cells and formulas on your worksheets.  

Tracing errors in a worksheet  

  

When Excel detects an error in a worksheet, it will display an error value in the cell as 

well as an Error Checking Smart Tag. You can click this smart tag to display a list of 

commands that can help you to trace and correct the error. The Formula Auditing toolbar 

also provides tools for doing this.  

  

To correct an error, select the cell that contains the error and then either click the Trace  

Error button (Formula Tab ->Formula Auditing Group-> Error Checking) or choose the  

Trace Error command (available through the Smart Tag options or the Formula Tab 

>Formula Auditing Group). When you do so, you will see tracer arrows pointing from 

the cell containing the error to other cells that contain values used by the formula in the 

first cell. Red arrows indicate possible sources of the error while blue arrows point to 

cells that probably are not the cause.  

  

  

Workgroup collaboration  
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Sharing a workbook makes it possible for several members of a workgroup to collaborate 

on the same set of data. For example, several sales managers could enter their respective 

regional sales figures in the same workbook, making it unnecessary to collect and 

consolidate the data manually.  

Sharing workbooks  

  

To share a workbook:  

  

• Open the workbook that you want to share.  

• Go to Review Tab ->Changes ->Share Workbook to open the Share Workbook dialog 

box, and then activate the Editing tab.  

• Check Allow changes by more than one user at the same time, and then click OK.  

• Save the workbook in a location where other users can access it.  

  

You can control how a workbook is shared by using the advanced tab of the Share 

Workbook dialog box. For example, under Update changes, you can select when file is 

saved to see other users‘ changes each time you save the workbook. You can also set the 

interval at which changes will be shown automatically.  

  
  

Merging workbooks  

  

You may need to share a workbook among users who cannot access the same file 

simultaneously. In such a situation, you can distribute copies of the shared workbook, 

allow users to make changes to their copies, and then merge those copies into a single 

workbook. To share a workbook that you intend to merge later:  

  

• Open the Share Workbook dialog box, activate the Editing tab, and check Allow 

changes by more than one user at the same time.  
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• On the Advanced tab, under Track changes, select Keep change history for. In the 

box, enter the number of days you want to allow users to make changes in the 

workbook, and then click OK.  

• Make copies of the workbook and distribute one to each user.  

  

After the users have made changes to their copies of the workbook, you can merge the 

copies into a single workbook. Here‘s how:  

  

• Choose Tools, Compare and Merge Workbooks to open the Select Files to Merge Into 

Current Workbook dialog box.  

• From the list, select the copy or copies of the workbook that contain changes you 

want to merge.  

• Click OK.  

Tracking changes  

  

You can analyze changes users have made to a workbook by using the Track Changes 

feature. This will tell you who made the changes, when they were made, and the original 

and changed values without having to manually compare the two workbooks. If your 

workbook is not shared, Excel makes the workbook shared automatically when you turn 

on the Track Changes feature.   

To highlight changes:  

  

• Go to Review Tab ->Changes ->Track Changes ->Highlight Changes to open the 

Highlight Changes dialog box.  

• If the workbook is not shared, check Track changes while editing. If the workbook is 

shared, this option will be checked by default.  

• Specify how you want changes to be tracked:  

• If you want view changes based on when they were made (for example, after a 

specific date), check when and then select the desired setting from the list.  

• If you want to view the changes made by a specific user, check whom and then select 

Everyone, Everyone but your own user name, or me.  

• If you want to view the changes made to a specific range of cells, check where and 

then enter the range.  

• Click OK.  

  

To review workbook changes and accept or reject them:  

  

• Open the workbook that has the tracked changes.  

• Go to Review Tab ->Changes ->Track Changes ->Accept or Reject Changes. You‘ll 

be prompted to save the workbook.  

• Click OK to save the workbook. The Select Changes to Accept or Reject dialog box 

appears.  
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• If you want view changes based on when they were made, check when and then select 

a time setting.  

• Click OK to open the Accept or Reject Changes dialog box. At the same time, the cell 

that contains the changed value will be highlighted. The dialog box displays 

information about each change, including the name of the person who made the 

change, the date and time when it was made, and other changes that will occur if you 

accept or reject the suggested change. You can scroll down to view the rest of the 

contents.  

• Click Accept to accept the change or Reject to keep the original value. The next cell 

with a changed value will be highlighted.  

  

Advanced formatting features  
  

Excel has all sorts of formatting features that you can use to quickly format data, increase 

consistency, or highlight particular data. These features include AutoFormat, conditional 

formatting, and merging styles.  

AutoFormat  

  

The AutoFormat feature provides single-step combinations of text formatting, borders, 

colors, and shading. The feature works best on data that is logically arranged in a table. 

By default, the AutoFormat feature will interpret the first row and column of a selected 

range as headings, and the last row and column as totals.  

  

• To apply an AutoFormat to a range:  

• Select the range to which you want to apply the format.  

• Go to Home Tab ->Styles Group ->Format a Table to open the AutoFormat galleries.  

• From the list of sample formats, select the format you want. You can go for new 

Table Style also.  

  

Conditional formatting  

You can use conditional formatting when you want to apply a format to a cell or range only 

if certain conditions are met. You can specify a maximum of 64 conditions. Each condition 

can have a separate format, such as a different font, border, or pattern. Conditional 

Formatting allows you to change the appearance of a cell, depending on certain conditions. 

What we'll do is to color the Overall Averages on our Student Exam spreadsheet, depending 

on the grade. Here's the spreadsheet we'll be working on.  
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• Highlight the cells with Overall Grades, which should be cells B11 to I11  

The Overall Averages range from 44 to 85. We'll color each grade, depending on a scale. 

A different color will apply to the following grades:  

• 50 and below  

• 51 to 60  

• 61 to 70  

• 71 to 80  

• 81 and above  

So five different bands, and a color for each. To set the Conditional Formatting in Excel 

2010, do the following:  

• With your Overall Averages highlighted, click on the Home menu at the top of 

Excel  

• Locate the Styles panel, and the Conditional Formatting item:  

  

The Conditional Formatting menu gives you various options. The easiest one is the Color 

Scales option. Select one of these and Excel will color the cell backgrounds for you:  
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That's not quite what we're looking for, though. We'd like to choose our own values. So 

click on More Rules, from the Color Scales submenu. You'll see the following rather 

complex dialogue box:  

  
The one we want is the second option, Format only cells that contain. This will allow us 

to set up our values. When you click this option, the dialogue box changes to this:  
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The part we're interested in is the bottom part; under the heading Edit the Rule 

Description. It says Cell Value and Between, in the drop down boxes. These are the 

ones we want. We only need to type a value for the two boxes that are currently blank in 

the image above. We can then click the Format button to choose a color.  

So type 0 in the first box and 50 in the second one:  

  

Then click the Format button. You'll get another dialogue box popping up. This is just 

the Format Cells one though. You've met this before. Click on the Fill tab and choose a 

color. Click OK and you should see something like this under Edit the Rule Description:  
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The Preview is showing the color we picked. So we've said, "If the Cell Value is between 

0 and 50 then colors the cell Red".  

Click OK on this dialogue box to get back to Excel. You should find that one of the cells 

has turned red. To format the rest of the cells, click on Conditional Formatting on the 

Styles panel again. From the menu, click on Manage Rules:  

  

You'll get yet another complex dialogue box popping up! This one:  
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Our first rule is already there - Cell Value Between. The only thing we're doing here is 

adding New Rules, similar to the one we've just set up. Click the New Rule button then. 

You'll see the exact same dialogue boxes you used to set up the first rule. Set a new color 

for the next scores - 51 to 60. Choose a color, and keep clicking OK until you get back to 

the Rules Manager dialogue box. It should now look something like this one:  

  

We now have to colors in our range. Do the rest of the scores, choosing a color for each. 

The scores are these, remember:  

• 50 and below  

• 51 to 60  

• 61 to 70  

• 71 to 80  
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• 81 and above  

When you've done them all, your dialogue box should have five colors:  

  

The colors above are entirely arbitrary, and you don't have to select the same ones we did. 

The point is to have a different color for each range of scores. But click OK when you're 

done. Your Overall Averages will then look something like this:  

  

Formatting your spreadsheet in this way allows you to see at glance relevant information. 

In the spreadsheet above, it's obvious who's failing - just look for the red cells!  

  

Macros  
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What is Macro?  

  

 VBA (Macro), which stands for Visual Basic for Applications, is a programming 

language developed by Microsoft Excel, along with the other members of Microsoft 

Office 2003, includes the VBA language (at no extra charge). In a nutshell, VBA is the 

tool that people like you and me use to develop programs that control Excel. Don't 

confuse VBA with VB (which stands for Visual Basic). VB is a programming language 

that lets you create standalone executable programs (those EXE files). Although VBA 

and VB have a lot in common, they are different animals.  

How to Start Recording a Macro  

  

Here are the steps to begin recording a new macro:  

  

• Plan exactly what you want to accomplish, and how to go about it. In fact, you should 

run through the precise keystrokes that you plan on recording before actually recording 

them.  

• Turn on the recorder using the View Tab ->Macro Group->Record Macro  

• Enter a meaningful Macro Name. The name can be up to 255 characters in length, 

consisting of letters, numbers, and under scores. There can be no spaces or other 

punctuation marks. (It is common to use underscores or proper case to separate words.) 

The name must begin with a letter.  

  

VALID  INVALID NAMES  REASON  

MyMacro  My Macro  contains a space  

Sales_Report  Sales.Report  contains a period  

Summary95  95Summary  starts with a numbers  

Get_YTD_Info  Y-T-D  contains illegal characters  

  

By default, the Description will include your name and the date. This text is place above 

the actual macro in the VBA module, as comments. You can add additional comments to 

explain the purpose of the macro.  

  

• At this point, you can click OK to begin recording. But there are additional settings that 

are made Available by clicking the Options button. You can create a format of a report, 

giving Company Name as the header. Insert date to the right corner of a page, also 

create a format of a table below it with proper headings having special fonts-bold etc.  

• After doing other formatting, stop recording the macro – either by clicking the stop 

recording button or using Tools, Macro, Stop Recording option from the main menu.  
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Other Options of Macro    

Shortcut Key   

  

Check this option if you want to assign a shortcut key for the macro you is about to 

record. Then enter a key that is to be used in conjunction with the Ctrl key to run the 

macro. If you check Shortcut Key, and enter T as the Ctrl+key, then after the macro is 

recorded, pressing Ctrl+T will run the macro.  

  

Store In   

  

These options specify where the macro to be recorded will be stored.  

  

Personal Macro Workbook   

  

This workbook, named PERSONAL.XLS, is automatically opened and hidden, each time 

you start Excel. This is a good place to store macros that you want available at all times.  

  

This Workbook   

  

Place the macro in the active workbook. If there is no active workbook, this option is not 

available.  

  

New Workbook  

  

A new workbook will be created, and the macro will be recorded in it.  

Stopping the Recorder  

  

There are two ways to stop recording:    

• Click the Stop tool.   

• Choose Tools, Record Macro, Stop Recording. Or, if there is no active workbook, 

choose File, Stop Recording.   

  

Running a Macro Using Menu Commands   

  

Go to View Tab ->Macro Group->Macro  
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Macros that are contained on all currently open workbooks are displayed in the list. To 

run a macro, select it from the list and click Run. The Macro dialog box provides several 

additional capabilities:  

  

Step  

  

  .  

Click this button to run the macro step by step. Stepping through a macro is 

useful for debugging purposes  

Edit  

  

    

The module containing the macro is activated, and the macro is displayed for 

editing purposes.  

Delete  

    

Deletes the selected macro. (You can also delete macros by activating the 

module and clearing the macro.)  

Options 

  

    

Lets you assign a shortcut key, add a command to Excel's Tools menu that 

runs the macro, and change the description of the macro.  

   

  

  

How to insert button into worksheet and assigning Macro 

to a Button  

   

• Click Office Button ->Excel Option ->Popular Tab and check on Show Developer tab 

in the Ribbon  

• Go to Developer Tab ->Controls Group ->Form Controls  Click the Button tool, and 

then draw the button on the worksheet.  

• The Assign Macro dialog box is displayed.  

• Select a macro from the list, and click OK.  

   

Here are two important implications of assigning macros to buttons:  
  

If the macro is in a different workbook than the button, a link is established to the 

workbook containing the macro. (The workbook will display in the Edit, Links dialog.) If 

the workbook containing the macro is closed, and you click the button, the workbook 

containing the macro is opened automatically, and the macro runs.  

  

Note: If you delete a button that is assigned to a macro, the macro is not deleted.  
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Excel 2010 specifications and limits  
  

Worksheet and workbook specifications and limits  

 Feature  Maximum limit  

Open workbooks  Limited by available memory and system resources  

Worksheet size  1,048,576 rows by 16,384 columns  

Column width  255 characters  

Row height  409 points  

Page breaks  1,026 horizontal and vertical  

Total number of characters that a  

32,767 characters  

cell can contain   

Characters in a header or footer  255  

Sheets in a workbook  Limited by available memory (default is 3 sheets)  

Colors in a workbook  
16 million colors (32 bit with full access to 24 bit color 

spectrum)  

Named in a workbook  Limited by available memory  

Unique cell formats/cell styles  64,000  

Fill styles  32  

Line weight and styles  16  

Unique font types  1,024 global fonts available for use; 512 per workbook  

Number formats in a workbook  
Between 200 and 250, depending on the language 

version of Excel that you have installed  

Names in a workbook  Limited by available memory  

Windows in a workbook  Limited by available memory  

Panes in a window  4  

Linked sheets  Limited by available memory  

Scenarios   
Limited by available memory; a summary report shows 

only the first 251 scenarios  

Changing cells in a scenario  32  

Adjustable cells in Solver  200  

Custom functions  Limited by available memory  

Zoom range  10 percent to 400 percent  

Reports  Limited by available memory  

Sort references  
64 in a single sort; unlimited when using sequential 

sorts  

Undo levels  100  
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Fields in a data form  32  

Workbook parameters  255 parameters per workbook  

Filter drop-down lists  10,000  

  

Calculation specifications and limits  

  

Feature                       Maximum limit  

Number precision  15 digits  

Smallest allowed negative 

number  
-2.2251E-308  

Smallest allowed positive 

number  
2.2251E-308  

Largest allowed positive 

number  
9.99999999999999E+307  

Largest allowed negative 

number  
-9.99999999999999E+307  

Largest allowed positive 

number via formula  
1.7976931348623158e+308  

Largest allowed negative 

number via formula  
-1.7976931348623158e+308  

Length of formula contents  8,192 characters  

Internal length of formula  16,384 bytes  

Iterations  32,767  

Worksheet arrays  Limited by available memory  

Selected ranges  2,048  

Arguments in a function  255  

Nested levels of functions  64  

User defined function 

categories  
255  

Number of available 

worksheet functions  
341  

Size of the operand stack  1,024  

64,000 worksheets that can refer to other  

Cross-worksheet dependency  
sheets  

Cross-worksheet array formula 

dependency  
Limited by available memory  

Area dependency  Limited by available memory  

Area dependency per 

worksheet  
Limited by available memory  
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Dependency on a single cell  
4 billion formulas that can depend on a 

single cell  

Linked cell content length 

from closed workbooks  
32,767  

Earliest date allowed for 

calculation  

January 1, 1900 (January 1, 1904, if 1904 

date system is used)  

Latest date allowed for 

calculation  
December 31, 9999  

Largest amount of time that  
9999:59:59  

can be entered  

  

Charting specifications and limits  
Feature     Maximum limit  

Charts linked to a worksheet  Limited by available memory  

Worksheets referred to by a chart  255  

  255  

  32,000  

Data points in a data series for 3-D charts  4,000  

Data points for all data series in one chart  256,000  

  

PivotTable and PivotChart report specifications 

and limits  
  

Feature  
           Maximum limit  

PivotTable reports on a sheet  Limited by available memory  

Unique items per field  1,048,576  

Row or in a PivotTable report  Limited by available memory  

256 (may be limited by available  

Report filters in a PivotTable report  

memory)  

Value fields in a PivotTable report  256  

Calculated item formulas in a PivotTable  

Limited by available memory report  

256 (may be limited by available  

Report filters in a   

memory)  
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Value fields in a PivotChart report  256  

Calculated item formulas in a PivotChart  

Limited by available memory report  

Length of the MDX name for a PivotTable  

32,767 item   

Length for a relational PivotTable string  32,767  

  

Shared workbook specifications and limits  
Feature  Maximum limit  

Users who can open and share a at the 

same time  
256  

Personal in a shared workbook  Limited by available memory  

Days that is maintained  32,767 (default is 30 days)  

Workbooks that can be merged at one 

time  
Limited by available memory  

Cells that can be highlighted in a 

shared workbook  
32,767  

Colors used to identify changes made 

by different users when change 

highlighting is turned on  

32 (each user is identified by a separate 

color; changes made by the current user are 

highlighted with navy blue)  

 

 
 

Short Cut Keys For 

Excel 2010 
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Select cells, columns, rows or object in worksheets and workbooks By using  keyboard shortcut keys  

Select the current region around the active cell (the current 

region is an area enclosed by blank rows and blank columns)  

  

CTRL + SHIFT + *(ASTERISK)  

Select the entire column  CTRL + SPACEBAR  

Select the entire row  SHIFT + SPACEBAR  

Select the entire worksheet  CTRL + A  

If multiple cells are selected, select only the active cell  SHIFT + BAKSPACE  

Extend the selection down one screen  SHIFT + PAGE DOWN  

Extend the selection up one screen  SHIFT + PAGE UP  

With an object selected, select all objects on a sheet  CTRL + SHIFT + SPACEBAR  

Alternate between hiding objects, displaying objects and 

displaying placeholders for objects  

  

CTRL + 6  

Show or hide standard toolbar  CTRL + 7  

Move and scroll on a worksheet or workbook by using 

shortcut keys  

  

Move between unlocked cells on a protected worksheet  TAB  

Move to the beginning of the row  HOME  

Move to the beginning of the worksheet  CTRL + HOME  

Move to the last cell on the worksheet  CTRL + END  

Move down one screen  PAGE DOWN  

Move up one screen  PAGE UP  

Move one screen to the right  ALT + PAGE DOWN  

Move one screen to the left  ALT + PAGE UP  

Move to the next sheet in the workbook  CTRL + PAGE DOWN  

Move to the previous sheet in the workbook  CTRL + PAGE UP  

Move to the next workbook or window  CTRL + F6 or CTRL + TAB  

Move to the previous workbook or window  CTRL + SHIFT + F6  

Move to the next pane  F6  

Move to the previous pane  SHIFT + F6  

Format data by using shortcut keys    

Display the style command (Format menu)  ALT + ‗ (APOSTROPHE)  

Display the cells command (Format menu)  CTRL + 1  

Apply the general number format  CTRL + SHIFT + ~ (TILD)  

Apply the Currency format with two decimal places (negative 

numbers appear in parenthesis)  

  

CTRL + SHIFT + $  

Apply the Percentage format with no decimal places  CTRL + SHIFT + %  

Apply the Exponential number format with two decimal places  CTRL + SHIFT + ^  
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Select cells with special characteristics by using shortcut 

keys  

  

Select the current region around the active cell (the current 

region is an area enclosed by blank rows and blank 

columns)  

  

CTRL + SHIFT + *(ASTERISK)  

Select the current array, which is the array that the active 

cell belongs to  

CTRL + /  

Select all cells with comments  CTRL + SHIFT + O  

Select only visible cells in the current selection  ALT + ; (SEMICOLON)  

Print and preview a document by using shortcut key    

Display the print command (File menu)  CTRL + P  

Keys for menus    

Show a shortcut menu  SHIFT + F10  

Make the menu bar active  F10 or ALT  

Show the program icon menu (on the program title bar)  ALT  + SPACEBAR  

Apply the date format with the day , month and year  CTRL + SHIFT + #  

Apply the time format with the hour and minute and indicate 

A.M. or P.M.  

CTRL + SHIFT + @  

Apply the number format with two decimal places, 1000 

separator, and – for negative values   

  

CTRL + SHIFT + !  

Apply the outline border  CTRL + SHIFT + &  

Remove all borders  CTRL + SHIFT + -  

Apply or remove bold formatting  CTRL + B  

Apply or remove italic formatting  CTRL + I  

Apply or remove an underling formatting  CTRL + U  

Apply or remove strikethrough formatting  CTRL + 5  

Hide rows  CTRL + 9  

Unhide rows  CTRL + SHIFT + (  

Hide columns  CTRL + 0 (ZERO)  

Unhide columns  CTRL + SHIFT + )  
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Edit data by using shortcut keys    

Edit the active cell and complete  F2 + Enter  

Cancel an entry in the cell or formula bar  ESC  

Edit the active cell and then clear it or delete the preceding character in 

the active cell as you edit the cell contents  

  

BACKSPACE  

Paste a name into a formula  F3  

Enter a formula as an array formula  CTRL + SHIFT + ENTER  

Display the Formula Palette after you have a valid function name in a 

formula   

CTRL + A  

Insert the argument names and parentheses for a function, after you type 

a valid function name in a formula  

  

CTRL + SHIFT +A  

Insert, delete and copy a selection by using shortcut keys    

Copy the selection  CTRL + C  

Paste the selection  CTRL + V  

Cut the selection  CTRL + X  

Clear the contents of the selection  DELETE  

Insert blank cells  CTRL + SHIFT + PLUS SIGN  

Delete the selection  CTRL + -  

Undo the last action  CTRL + Z  


